Ubuntu 6.10 Edgy Eft

Estoy en estos momentos en proceso de actualización del Ubuntu 6 de mi portátil a 6.10. La forma que estoy actualizando es simplemente siguiendo las instrucciones de la página de Ubuntu con apt-get.

El motivo de escribir esta anotación es porque a mitad del apt-get dist-upgrade , cuando ya estaban descargados todos los paquetes y se estaban instalando, he abierto otro terminal y he visto que habia cambiado el font. Asi que he ido a mirar, en la misma consola en la que estaba corriendo en dist-upgrade, el font antiguo para anotarlo. Con tan mala suerte que por error he cerrado la ventana y el upgrade se ha quedado a medias. ¡HORROR!.
Por si a alguien le pasa algo parecido alguna vez, los pasos que he seguido han sido los siguientes:

Al volver a correr el dist-upgrade, tengo el mensaje:

jmiguel@halebopp:~$ sudo apt-get dist-upgrade
Password:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. 

¡HORROR!

Asi que ejecutamos el dpkg –configure -a recomendado para que reconfigure fonts y no se cuantas cosas más (imagino que lo que le faltaba del paquete que estaba instalando). Despues de eso, apt-get dist-upgrade sigue sin estar contento:

jmiguel@halebopp:~$ sudo apt-get dist-upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo información de estado... Hecho
Calculando la actualización... Listo
Los siguientes paquetes se han retenido:
  hpijs python-adns python-clientcookie python-crypto python-egenix-mxproxy 
  python-egenix-mxstack python-egenix-mxtexttools python-egenix-mxtools python-gadfly
  python-htmlgen python-htmltmpl python-imaging  python-imaging-sane python-jabber
  python-kjbuckets python-ldap python-mysqldb python-pam python-pexpect python-pgsql
  python-pylibacl python-pyopenssl python-pyxattr python-reportlab python-simpletal
  python-soappy python-sqlite python-syck python-xmpp xserver-xorg-core 
  server-xorg-input-elographics xserver-xorg-input-evdev 
  xserver-xorg-input-kbd xserver-xorg-input-mouse xserver-xorg-input-synaptics

0 actualizados, 0 se instalarán, 0 para eliminar y 35 no actualizados.

Y de ahi no pasa. (Y cualquiera se atreve a reiniciar asi).

Tras buscar un poco sin encontrar la solucion exacta (con el recien instalado firefox 2.0 corriendo con las librerias antiguas, que asi es como estoy escribiendo esto) he ejecutado un apt-get install [todos los paquetes de arriba] (con el /etc/apt/sources.list nuevo, apuntando a los nuevos repositorios y …. aqui estoy esperando a que termine.
.
.
.
Terminó. Ejecuto de nuevo apt-get dist-upgrade…

root@halebopp:~# apt-get dist-upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo información de estado... Hecho
Calculando la actualización... Listo
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.

Ok.. vamos a reiniciar… ¿funcionará?….

.
 .
 \|/
- * -
 /|\
.
.

Yoohooo! Ya estamos aqui, con el Edgy Eft funcionando.

Primeras impresiones: esto carga más rapido que antes, en especial los gDesklets. El nuevo firefox 2 (en inglés) incluye corrector ortográfico, asi que me esta amablemente subrayando todo este texto en rojo. Los font de la consola, efectivamente han cambiado, ahora parecen más legibles
Tiene buena pinta esta nueva versión de Ubuntu, espero que no haya secuelas despues de la aventura.